Tagged in: vSphere create VM

Installing a server on our hypervisor with vSphere 6.0

Installing a server on our hypervisor with vSphere

So, where are we?

We have a virtual server with exsi hypervisor running on as a base for a virtual lab,  now as a (out of touch) windows domain admin i think installing windows server to refresh myself is a good a place as any to start. Since the last time i administered a domain was when server 2008 R2 was new and starting to get adopted, i figure ill grab myself a evaluation copy of windows server 2016 and see whats new. So I’ve grabbed an ISO of that and im ready to get started.

So here i am, a vSphere front screen,  now Inventory, Administration and Recent Tasks, seam like reassuring fields to have connecting to a hypervisor, especially when you can see power events in t the tasks pane.  looks like i’m good to go.

Now as a noob, I must confess it isn’t entirely obvious where to go to start creating virtual machines, but hey,  i figure inventory is the most likely of the options presented to me.

so opening inventory i find:


After that brief moment of confusion, everything is much clearer now another MMC-like window with a nice explanation of what a virtual machine is and a nice “create new virtual machine link”

that’s more like it, now i’m happy again, so lets do that and create a Virtual machine  for windows server 2016.

Up comes another great Wizzard,  prompts you for each configuration option.  Now this is so quick and easy i am basically going to accept defaults at every stage where possible, after all a vanilla 2016 install must be one of the most common tasks performed and i want to see how it does.

Just calling it testvm for now

again default storage location.

I changed from the default, to server 2016 (64bit).

Default nework configuration looks good to me.

again I accept the defaults, reducing the disk to 10Gb assuming i can always grow it if necessary

Click finish, and in a blink of an eye, its done and all i have to show for it is a new item under inventory;- testvm

looks like it worked, lets see if we can get windows installing on it

nice to not the create virtual machine task is registered in recent tasks, lets click on testvm and see what we can do,

first thing i notice is we get a toolbar with play pause and stop buttons,  hitting the play button.

does very little. apart from putting a play icon over the virtual machine, and adding a power on virtual machine event in the task log.

ok makes sense, its for virtual servers, which are usually headless and remote, and from past playing with virtual machines at cambridge i know i need to connect to the console of the virtual machine. lucky for me in the new toolbar one of the icons has a hover over tooltip that says “launch the virtual machine console”, so i hit it:

and i’m greeted by a failed pxe boot screen,  again makes sense i haven’t given it an install media and the VM is network booting by default. very useful for remote installs..

so we need to give the virtual machine a install media, i have an iso and as i’m too lazy to burn it i will try and mount it, so closing down the console and shutting down the vm, lest see if we can mount the iso to install from.  Right clicking on the testvm i have an option to edit settings..

now under CD/DVD drive Device type we have client device with a message telling us to power on the device then click on the connect cd/dvd button in the toolbar.

sounds sensible, lets try that..

on the 3rd reboot i worked out to press F2 to enter the bios of the VM in order to give me enough time to mount the ISO to boot from it.

now im not going to talk you through installing windows, i’m sure you are capable of that,   and in my next post i will mention any hurdles i had.

off to install windows, hope you enjoyed it.

Tchau for now